The UK C1 Forum - Not logged in
Forum Home Help Search Register Login OpenID
Previous Next Up Board C1 Information / Repairs - Faults & Fixes (Page 4)
1 2 3 4 5 6 7 8 ... 55 Previous Next
Topic Poster Posts Last Post
intermittent abs lights / battery drain edbialek 9 16.07.17 10:23
_Engine doesn't run rockstedy 40 12.07.17 07:46
Oil light still coming on after new pressure switch Filbert 5 16.06.17 16:08
Oil pressure switch question Filbert 13 06.06.17 19:19
Violett unknown cable magni900 3 29.05.17 07:23
C1 not used for 5 yrs, ran for 10 mins and now not starting! Chrisw 9 26.05.17 17:34
Dodgy Indicator Clunkfish 7 23.05.17 20:23
C1 Problems after Starting Sankti 4 15.05.17 17:21
bmw c1 alarm and immobilizer removal stephen2401 1 05.05.17 07:21
Bike lost "go forward" ability! Spud Im Irish 9 27.04.17 20:40
How to check ABS sensor? Bertone 19 26.04.17 09:22
Windscreen washer fluid pipe patc50 3 22.04.17 19:54
Engine stalls when passing minor potholes Peter77 10 21.04.17 14:56
Oil & temp lights burning WITHOUT ingnition switched on josmarlangner 16 21.04.17 10:57
Driven variator p.gill 2 20.04.17 09:24
Hep to identify this? patc50 4 18.04.17 17:28
ECU for both, 125 and 200 cc identical??? josmarlangner 7 17.04.17 08:40
Piston rings change? Bertone 8 25.03.17 15:11
End connector of spark plug cable broken Bertone 13 25.03.17 10:21
Remove water pump housing? Bertone 9 24.03.17 19:19
Handlebar/steering squeak tomlem 1 20.03.17 10:02
Front wheel bearing came loose? Spud Im Irish 5 16.03.17 17:09
Another non starter Spud Im Irish 3 16.03.17 12:44
Brake lever micro switch p.gill 2 13.03.17 20:12
Oil Pressure Light Switch Cautionary Tale Gerard 1 03.03.17 15:43

Powered by mwForum 2.16.1 © 1999-2008 Markus Wichitill