The UK C1 Forum - Not logged in
Forum Home Help Search Register Login OpenID
Previous Next Up Board C1 Information / Repairs - Faults & Fixes
1 2 3 4 5 6 7 8 ... 52 Previous Next
Topic Poster Posts Last Post
Mayonaise in the coolant Bertone 26 16.10.17 08:28
Oil Leakage aware 39 11.10.17 10:53
Engine idel speed increasing Spud Im Irish 10 06.10.17 09:24
rings leonm 1 29.09.17 14:06
all boards leonm 1 16.09.17 15:40
ABS failure with error code "relay ABS valve 414" josmarlangner 5 15.09.17 20:11
New C1 won't pull away properly and hesitates at speed Pinbot 4 12.09.17 13:30
Min connections to start engine? Spud Im Irish 16 11.09.17 13:34
error code:0x443(1091)tank vent valve LCY71 6 07.08.17 21:21
Crash element replacement, plastic print or mdf retro edbialek 10 07.08.17 17:55
Cylinder burned Chrisw 18 30.07.17 22:06
intermittent abs lights / battery drain edbialek 9 16.07.17 10:23
_Engine doesn't run rockstedy 40 12.07.17 07:46
Oil light still coming on after new pressure switch Filbert 5 16.06.17 16:08
How to repair worn symbols? Bertone 1 07.06.17 09:22
Oil pressure switch question Filbert 13 06.06.17 19:19
Violett unknown cable magni900 3 29.05.17 07:23
C1 not used for 5 yrs, ran for 10 mins and now not starting! Chrisw 9 26.05.17 17:34
Dodgy Indicator Clunkfish 7 23.05.17 20:23
C1 Problems after Starting Sankti 4 15.05.17 17:21
bmw c1 alarm and immobilizer removal stephen2401 1 05.05.17 07:21
Bike lost "go forward" ability! Spud Im Irish 9 27.04.17 20:40
How to check ABS sensor? Bertone 19 26.04.17 09:22
Windscreen washer fluid pipe patc50 3 22.04.17 19:54
Engine stalls when passing minor potholes Peter77 10 21.04.17 14:56

Powered by mwForum 2.16.1 © 1999-2008 Markus Wichitill